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Qué es R Markdown.
Tus datos cuentan una

historia. Cuentalo con
R Markdown.

Cémo funciona.
Seis pasos para crear
tu propio informe.

Metadatos (YAML).
Personaliza el formato
de tu informe.

Codigo y resultados.
Utiliza fragmentos y
codigo en linea para
informar de tus
resultados.

Narra el analisis.
Incluye texto y dale el
formato que desees
con el Visual Editor.

Reproducible y
reutilizable.

Ahorra tiempo vy evita
errores con R
Markdown..

;Quieres mas?.
Descarga la hoja de
frucos, conoce nuestra
lista de lecturas
recomendadas, blogs
y mas ebooks.
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Maxima
ForMACION

COMO FUNCIONA R MARKDOWN

Abre

En RStudio IDE ve a File > New File >

CREA TUS INFORMES CON R MARKDOWN

Personaliza

Selecciona el formato de salida (e.g. PDF,

RMarkdown para abrir un nuevo archivo .Rmd Word, efc.) y las opciones que desees (e.g.

Se abrird una plantilla editable con la que

tabla de contenidos, logos, temas, etc.) en

crear tu propio informe. los metadatos (YAML) del encabezado.

7 Jo
Incluye codigo
Incluye eédigo R (o Python) dentro de
fragmentos (echunks). Corre el cédigo por

Guarda y compila

Presiona el botén Kint para guardar el informe

) con extensién .Rmd y exportarlo al formato
linea, por chunk o todos a la vez. _ ) . L
seleccionado. Obtén una previsualizacion

de tu trabajo mientras escribes.

Comparte

Puedes utilizar GitHub para compartir tu

Escribe texto

Incluye tu narracién de los andlisis y

resultados. Agrega tablas, figuras, , .
trabajo y colaborar con tus compafieros.

imagenes y citas. Dale formato mediante

sintaxis o con el Visual Editor de RStudio.

RENDERED OUTPUT .- file path to output document
SOURCE EDITOR —

report.html Open in Browser Find “s, Publish ~

~|Desktop/report/report.html

find in documen'{

@]- P - 5. Save and Render RSN bl"'r}‘- .
B - » publish to
2 reporsam , -~ Document Title  fbecom
YA ekt - - W-/ ¢ S ERun - | 5~ (3 shinyapps.io

- — o : |RMarkgown ¢ | Author Name grp—
2 title: "Document Title" ST Insert  goto run Cﬁde Including Plots - RStudio Connect
3 author: "Author Name" pI‘EVI.E‘W code code chun (5) 3 . * R Markdown
B output: location chunk chunk show . -
5 html_document : outline D R IS
6 toc: TRUE :
- . 4, Set Output Format(s) R Markd N eload document
o - | and Options d ow
9~ {r setup, inc™ 3 .
10 knitr::opts_chunk$set(echo = TRUE) : This is an R Markdown document. Markdown is a simple formatting

syntax for authoring HTML, PDF, and MS Word documents. For more

12 -
13 ~ ## R Markdown 3. Write Text unall details on using R Markdown see http://rmarkdown.rstudio.com.

15 This is an R Markdown document. ) pFEViOUS (e
16 Markdown is a simple formatting delfY chunks Y
17 syntax for authoring HTML, PDF, ChU_nk run
18 and MS Word documents. options : Jcurrent i
19 : < chunk - ## speed dist
20~ """ {r cars} T XN . ## Min. : 4.0 Min. : 2.00
21 summary(cars) 2. Embed Code . ## 1st Qu.:12.0 1st Qu.: 26.00
=3 ; ## Median :15.0 Median : 36.00
18:23 E3 R Markdown = R Markdown, ## Mean :15.4 Mean : 42.98
Console Terminal R Markdown Jobs = ## 3rd Qu.:19.0 3rd Qu.: 56.00
e ~[Desktop/report/report.Rmd ## Max. :25.0 Max :120.00
Qutput created: report.html - e report. html '2.9KB Jul'9, 2021, 4:35PM 7T
VISUAL EDITOR insert citations style options .
&  report.Rmd _ -
s X @ Knit - i -8 - +Run ~ &~ O
Normal - B I U «<p» k| = } .'@ & Format ~ Insert ~ Table ~

R Markdown_ Lt In‘FOrme fina‘

Including Plots
This is an R Markdown document. Markdown is a simple formatting "‘-._add[edit
syntax for authoring HTML, PDF, and MS Word documents | attributes (htM‘ PDF word etc )
9 9 9 *

Nota geek:
compilar = renderizar




MaXxXimo

CREA TUS INFORMES CON R MARKDOWN FORMACION

title: "My Document"
author: "Author Name"

output:
html_document: ' |hdentformat 2 characters,

___ toc: TRUE indent options 4 characters

poTEe ORI CREATES Utiliza el encabezado para
ml_document .html

D fri seleccionar el formato de|
word_document Microsoft Word (.docx)
powerpoint_presentation  Microsoft Powerpoint (.pptx) d ocumento (O Utp ut:
odt_document OpenDocument Text )
rtf_document Rich Text Format html_document) y personalizar
md_document Markdown . o
github_document Markdown for Github |aS OPCIones de Sallda (eg tOC)
ioslides_presentation ioslides HTML slides
slidy_presentation Slidy HTML slides
beamer_presentation* Beamer slides

* Requires LaTeX, use tinytex::install_tinytex()
Also see flexdashboard, bookdown, distill, and blogdow

MS wora
MS PPT

IMPORTANT OPTIONS DESCRIPTION

anchor_sections Show section anchors on mouse hover (TRUE or FALSE) f -
citation_package The LaTeX package to process citations ("default", "natbib", "biblatex") X
code_download Give readers an option to download the .Rmd source code (TRUE or FALSE) X
code_folding Let readers to toggle the display of R code ("none", "hide", or "show") X
Css CSS or SCSS file to use to style document (e.g. "style.css") X
N Ota geek p a l'a dev Graphics device to use for figure output (e.g. "png", "pdf") X X
./ df_print Method for printing data frames ("default", "kable", "tibble", "paged") X X X X
crear ESta sSeccion fig_caption Should figures be rendered with captions (TRUE or FALSE) il A il ¢
highlight Syntax highlighting ("tango", "pygments", "kate", "zenburn", "textmate") X X X
d e m a n e ra includes File of content to place in doc ("in_header", "before_body", "after_body") X X
lnte ra Ctlva Utl | |Za el keep_md Keep the Markdown .md file generated by knitting (TRUE or FALSE) X X X X
keep_tex Keep the intermediate TEX file used to convert to PDF (TRUE or FALSE) X
Ad d i 1] ym It h i S latex_engine LaTeX engine for producing PDF output ("pdflatex", "xelatex", or "lualatex") X
reference_docx/_doc docx/pptx file containing styles to copy in the output (e.g. "file.docx", "file.pptx") X X
theme Theme options (see Bootswatch and Custom Themes below) X
toc Add a table of contents at start of document (TRUE or FALSE) X X | X%
toc_depth The lowest level of headings to add to table of contents (e.g. 2, 3) XX X X
toc_float Float the table of contents to the left of the main document content (TRUE or FALSE) X

Use ?<output format> to see all of a format's options, e.g. ?html_document

cQuieres mas?

e Utiliza parametros para reutilizar
el informe con nuevas entradas
(e.g. datos, valores, etc.).

e Inserta citas desde un archivo
bibliografico.

o Utiliza plantillas predefinidas.

e Personaliza el informe con estilo
CSS.

PAGINA 5



https://github.com/r-lib/ymlthis
https://es.r4ds.hadley.nz/r-markdown.html
https://es.r4ds.hadley.nz/r-markdown.html
https://rstudio.github.io/visual-markdown-editing/citations.html
https://bookdown.org/yihui/rmarkdown/document-templates.html
https://rstudio.github.io/visual-markdown-editing/additional.html

Fragmentos (chunks) de codigos

+ LS SN A NN
Inserta un fragmento con el botdn d 7 o escribe tu cédigo rodeado con  {r}y .

;)

Ar} e Define las opciones globales en el
dim(iris) dim(iris) primer fragmentos de cédigo
- mediante la funcién

# [1] 150 5 knitr::opts_chunk$set(), usa por
ejemplo message=FALSE para
eliminar mensajes.

ELIGE QUE QUIERES VER

Dentro de las llaves y luego de la r, indica tus opciones (e.g. eval=FALSE) o etiquetas.

Para omitir los resultados de su informe final (y no Para omitir el cédigo del informe final (mientras
ejecutar el cédigo) agregue el argumento eval = se incluyen los resultados) agregue el

FALSE entre corchetes y después r. Esto colocard argumento echo = FALSE. Esto colocard una
una copia de su cddigo en el informe. copia de los resultados en su informe.

Here’s some code Here’s some code Here’s some code Here’s some code
7 {r eval=FALSE} “*"{r echo=FALSE}

dim(iris) dim(iris) dim(iris) ## [1] 150 5

S - e -

Cédigo enel texto  Tablas de datos

Inserta r <code> dentro del texto. El Visualiza los datos mediante tablas

cédigo es evaluado al compilar y los utilizando la funcién kable(data, caption)
resultados aparecen en el texto.

Output data frames as tables using
Two plus two Two plus two kable(data, caption).

equals 'r 2 + 2. equals 4.
S rr)
data <- faithful[l:4, ] |

- knitr::kable(data, l
caption = "Table with kable")

PAGINA 6
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CREA TUS INFORMES CON R MARKDOWN FORMACION

NARRA TU HISTORIA

@ | test.Rmd*
B s Q| @ Knit - - 1 Insert ~

B I «» | ¥ | Format = | Insert ~ | Table =

title: "R Markdown Cookbook”
author: "Yihul Xie, Christophe Dervieux, Emily Riederer®

date: *"r Sys.Date()"™"

Preface

R Markdown is a powerful tool for combining analysis and reporting into the
same document. Since the birth of the rmarkdown package [aR-rmarkdown] in
early 2014, R Markdown has grown substantially from a package that supports
a few output formats, to an extensive and diverse ecosystem that supports the
creation of books, blogs, scientific articles, websites, and even resumes.

Chapter Title Sections
Installation
Conceptual Overview

Basics

LaTeX

e

<>

agram iffustrating how an R Markdown document is
= 3/ output document.

| Lock ratio

PAGINA 7
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“EVERY ANALYSIS
YOU DO ON A
DATASET WILL HAVE
TO BE REDONE 10-15
TIMES BEFORE
PUBLICATION. PLAN
ACCORDINGLY .”

Trevor A. Branch.

R MARKDOWN CREA INFORMES
REPRODUCIBLES Y REUTILIZABLES

) studio @ 6

R Markdown te permite crear
informes reproducibles y
reutilizables.

Olvidate del Copy & Paste, deja
de editar cada tabla y figura en
un nuevo documento.

Con R Markdown puedes rapidamente:

e Corregir errores en los datos o agregar
algunos casos extra.

e Realizar los cambios propuestos por un
revisor.

e Llevar unregistro de los pasos
realizados (a diferencia de softwares
como Excel)

e Compartir tu trabajo con tus colegas,
con control de versiones.

Simplemente actualiza y compila
nuevamente el informe con un solo clic.

Ahorra tiempo y evita errores con R

Markdown.
PAGINA 8




CREA TUS INFORMES CON R MARKDOWN

rmarkdown : : CHEAT SHEET

chunk, or all at once.
e Write text and add tables, figures, images, and

SOURCE EDITOR

What is rmarkdown? s ewrie
Rmd files - Devel ode and L g Jeoave sad handes /.
.Rm s - Develop your code an e —=
9o ideas side-by-side in a single i X | ik = - - - T O
i document, Run code as individual i- : = . : ] e Eiation
c chunks or as an entire document. 7 ritle: “Docusent Title” SEE | insert  goto runcode SR .
@ 3 outhor: "Author Nemew Preview code  code  chunk(s) : .
Dynamic Documents - Knit together & output location chunk chunk show
plots, tables, and results with 5 htal_documsent outline
narrative text. Render to a variety of o e 4, Set Output Format(s) .
formats like HTML, PDF, MS Word, or M and Options =
M5 Powerpoint. B v .
* 1 mitr it cl Sset(echo
- E‘ Reproducible Research - Upload, link 1- %
to, or attach your report to share. e )
@<y Anyonecanread or run your code to - run all
reproduce your work. 15 This is on R Markdosn docusent. . previpus '
16 Morkdown is o sisple formatting madify chunks .
17 symtax for outhoring HTML, POF, chunk : run '
18  ond M Bord documents. options current
Workflow i
- {r cars} ' Xz
EN mmar ey 2. Embed Code
€ Openanew .Rmd file in the RStudio IDE by - —
going to File > New File > R Markdown. A1) 18 Mo £ A .
= s Console  Terminal - R Markdown - Jobs =
Embed code in chunks. Run code by line, by [ T —————r f

RENDERED OUTPUT

file path to output document

L] L] Dok topireperijreport i
report.hbml Open in Browser T Publish -
find in document bl'..h )
H publish to
Document Title  [uon
shinyapps.io,

Authar Name RStudio Connect

+ R Markdows

# Including

R Markdown

This is an R Markdown document. Markdown is a simpbe formatting
syntax for authoring HTML, PDF. and MS Word docume
details on using R Markdown see hitp://rmarkdown.rst

reload decument

For more

summary (cars)

dint
Min. + 1.00
Ist Qu.: 26.00
Madian : 16.00

e spoed
#F  Min. 1 4.
M lat Qu.al2.
##  Modian 11

E ]

##  Moan 115, Mean : 42.98
* Jrd Qu.il®. Jrd Qu.: 56.00
# Max. 125. Hax. 1120.00

par BOFONE TS 0TI AT T

citations. Format with Markdown syntax or the
RStudio Visual Markdown Editor.

o Set output format(s) and options in the YAML

VISUAL EDITOR

insert citations style options

2 reporthmd -
header. Customize themes or add parameters = Q| Kok - @ - Hhun - -
to execute or add interactivity with Shiny. — = sl ' “® | BB | Formx = | lnowr = | Table ~
Save and render the whole document. Knit R Markdown i —
periodically to preview your work as you write.
This is an R Markdown document. Markdown is a simple formatting . add/edit
Share your work! synnax for authoring HTML, PDF, and MS Word documents ] “attributes

Embed Code with knitr

CODE CHUNKS OPTION DEFAULT EFFECTS
Surround code chunks with *** frland *** oruse echo TRUE  display code in output document
the Insert Code Chunk button, B Add a chunk label anor aLse  TRUE (display error messages in dac)
and/or chunk options inside the curly braces after r. FALSE (stop render when error occurs)
eval TRUE  runcodein chunk
***{r chunk-label, include=FALSE} include TRUE  include chunk in doc after running
summary (mtcars) message TRUE  display code messagesin document
i warning TRUE  display code warnings in document
— ":5';5'{dassthaqu hresultls}J
resu "markup" "hide" {don't display results
SET GLOBAL OPTIPNS . "hold" [put all results below all code)
Set options for the entire document in the first chunk. fig.align  “default” "left”, "right’, or "center”
**“{r include=FALSE} fig.alt NULL  alt text for a figure
knitr::opts_chunk$set(message = FALSE) fig.cap NULL  figure caption as a character string
iy fig.path “figure/™ prefix for generating figure file paths
2::::?“:“ 7 plotdimensions ininches
IHL"{E CODE o < . out.width rescales output width, e.g. "75%", "300px”
'a'ls::: derr :ﬁdr:sﬂulﬁt: te:"s:(s:ttl:&s. Codeisevaluated 5, FALSE  collapse all sources & output into a single block
PR : comment “HR" prefix for each line of results
"Built with "r getRversion() " —"Builtwith 4.1.0° child MULL  files(s) to knit and then include
purl TRUE include or exclude a code chunk when

GStudio

extracting source code with knitr::purl()

See more options and defaults by running str(knitr::opts_chunk$get())

RStudio® is a trademark of RStudio, PBC « CC BY SA RStudio « info@rstudio.com « 844-448-1212 » rstudio.com « Learn more at rmarkdown.rstudio.com .

Insert Citations

Create citations from a bibliography file, a Zotero library,
or from DOI references.

BUILD YOUR BIBLIOGRAPHY
Add BibTeX or CSL bibliographies to the YAML header.

title: "My Document™
biblicgraphy: references.bib
link-citations: TRUE

*

If Zotero is installed locally, your main library will
automatically be available.

Add citations by DOI by searching "from DOI" in the
Insert Citation dialog,
INSERT CITATIONS

+ Access the Insert Citations dialog in the Visual Editor
by clickin%tt;e @ symbol in the toolbar or by clicking
Insert > Citation.

+ Add citations with markdown syntax by typing [@cite]
or @cite.

Insert Tables

Qutput data frames as tables using

kable{data, caption). v
i {r} s m
data <- faithful[l:4, ] . w
knitr::kable(data,

caption = "Table with kable")

Other table packages include flextable, gt, and kableExtra.

Write with
Markdown

rmarkdown

The syntax on the left renders as the output on the right.

Plain text.

End a line with two spaces to
start a new paragraph.

Also end with 2 backslashy,
to make a new line.

“italics® and "*bold"*
superscripth2*/subscript~2~
~~strikethrough--

escaped: " \_\\

endash: ==, emdash: ===

# Header 1
#if Header 2

HH#HY Header &

-unordered list
-item 2
iterm 2a {indent 1 taby)
-item 2b

1. ordered list

2 item2
-itemn 2a {indent 1 tab)
-itern 2b

<link wrl=
[This is a link.]{link url)
[This is anather link](id].
At the end of the document:
[id]: link url
![Caplion]iimazjge.png]
or ![Caption][id2)
At the end of the document:
[id2): image.png

“verbatim code”

multiple lines
ofverbatim code

= block quotes

equation: Serfi\pi}+1=0%

equation block:
S$E = meh{2}55

horizontal rule:

| Right | Left | Default | Center|
[rvwraacfsemmeen|sermemmnnafsamennecs]
|12]12] 12| 12|
|123|123|123|123|
[1]1120L]

HTML Tabsets

# Results { tabset}
i Plots text

et

i Tables
more text

Plain text.

End a line with two spaces to
start a new paragraph.

Also end with a backslash
to make a new line,

italics and bold
superscript?/subscriptz
strikethrough
escaped: * _\

endash: -, emdash: —

Header 1
Header 2

Header &6

+ unordered list

- item2
= item 2a (indent 1 tab)
= item 2b

1. ordered list

2, item 2
= item 2a (indent 1 tab)
+ item 2b

hittp:/fwww, rstudio.com/

This is a link.

This is another link.

Caption.
verbatim code

multiple lines
of verbatim code

block quotes

equation: e+ 1 =0

equation block:
E=me?

harizontal rule:

Right Left Default  Center
12 12 12 12
123 123 123 123

11 1 1

Results
Plots Tables

text

rmarkdown 2.9.4 « Updated: 2021-08

Render

When you render a

rmarkdown

Set Output Formats and their Options in YAML Bk
FL=a
Use the document’s YAML header to set an output IMPORTANT OPTIONS ~ DESCRIPTION Epsg
format and customize it with output options. anchor_sections Show section anchors on mouse hover (TRUE or FALSE) X
= citation_package The LaTeX package to process citations ("default”, "natbib", "biblatex") X
TILIS. T Eoculene de_download Give read tion to download the Rmd ode (TRUE or FALSE) X
author: "Author Name" code_downloa ive readers an option to download the .Rmd source code or
DUEPU{ : 4 code_folding Let readers to toggle the display of R code ("none”, "hide", or "show™) X
tml_document: |ndent format 2 characters ' i =
toc: TRUE indent options 4 :haracters, €ss €55 or 555 file to use to style document (e.g. "style.css™) X
T dev Graphics device to use for figure output (e.g. "png", "pdf") X X
OUTEUT FORMAT CREATES df_print Methaod for printing data frames ("default”, "kable", "tibble", "paged") XXX
html_document P fig_caption Should figures be rendered with captions (TRUE or FALSE) B I3 B B
pdf_decument* pdf highlight Syntax highlighting {"tango”, "pygments”, "kate", "zenburn®, "textmate") X X X
word_document Microsoft Word (.docx) includes File of content to place in doc ("in_header"”, "before_body", “after_body") X X
powerpoint_presentation  Microsoft Powerpaint (.pptx) keep_md Keep the Markdown .md file generated by knitting TRUE or FALSE) X XXX
K oA OpenDocument = keep_tex Keep the intermediate TEX file used te convert to PDF (TRUE or FALSE) X
rtf_document Rich Text Format i = e e = . - =
md_document Markdown latex_engine LaTeX engine for producing PDF output ("pdflatex”, "xelatex", or "lualatex”) X
github_document Markdown for Github reference_docx/_doc  docx/ppix file containing styles to copy in the output (e.g. "file.docx”, "file.pptx”) X X
ioslides_presentation ioslides HTML slides theme Theme options (see Bootswatch and Custom Themes below) X
slidy_presentation Slidy HTML slides toc Add a table of contents at start of document (TRUE or FALSE) X
beamelr_presemaﬂon‘.' ?eamer "'."des toc_depth The lowest level of headings to add to table of contents (e.g. 2, 3) XX XX
i o e B ) toc_float Float the table of contents to the left of the main document content (TRUE or FALSE) X

Also see flexdashboard, bookdown, distill, and blogdown.

More Header Options

PARAMETERS
Parameterize your documents to reuse with new
inputs (e.g., data, values, etc.).

1. Addparameters params:

in the header as state: "hawaii"
sub-values of -
params. iy
data <- df[, params$state]
2. Call parameters summary (data)

in code using
paramsS<names=,
H % 4 & EsHTML -

3. Setparameters y—

with Knit with i s

Parametersorthe = g"; “‘m .

params argument e

of mndgru._ Knit with Parameters...
REUSABLE TEMPLATES

1. Create a new package with a inst/rmarkdown/
templates directory.

2. Add a folder containing template.yaml (below)
and skeleton.Rmd (template contents).

name: "My Template"

3. Install the package to access template by going to
File > New R Markdown > From Template.

GStudio

Use ?<output format> to see all of a format's options, e.g. Thtml_decument

BOOTSWATCH THEMES

Customize HTML documents with Bootswatch
themes from the bslib package using the theme
output option.

Use bslib::bootswatch_themes() to list available
themes.

title:
author:
output:
html_document:
theme:
bootswatch: solar

"Document Title"
"Author Name"™

CUSTOM THEMES

Customize individual HTML elements using bslib
variables. Use 7bs_theme to see more variables.

output:
html_document:
theme:
bg: "#121212"
fg: "HE4E4E4"
base_font:

google: "Prompt"

Maore on bslib at pkgs.rstudio.com/bslib/.

STYLING WITH CSS AND SCSS

Add CSS5 and SCSS to your document by adding a
path to a file with the css option in the YAML header.

title: "My Document"
author: "Author Name"
output:
html_document:
css: "style.css"

Apply CSS styling by writing HTML tags directly or:
« Use markdown to apply style attributes inline.

Bracketed Span

A [green]{.my-color} word, A green word.
Fenced Div

o {my-color}

All of these words
are green.

All of these words
are green.

« Use the Visual Editor. Go to Format = DivfSpan and
add €SS styling directly with Edit Attributes.

Jmy-css-tag -

This is a div with some text init.

document, rmarkdown:

1. Runs the code and embeds
results and text into an .md
file with knitr.

2. Converts the .md file into the output format with
Pandoc.
md. . L’d“ voe |
| DoC

Save, then Knit to preview the document output.
The resulting HTML/PDF/MS Word /etc. document will
be created and saved in the same directory as

the .Rmd file.

Use rmarkdown::render() to render/knit in the R
console. See ?render for available options.

Share
o

Publish on RStudio Connect
@

knitr

R

to share R Markdown documents
securely, schedule automatic .
updates, and interact with parameters in real time.

rstudio.com/products/connect/

INTERACTIVITY

Turn your report into an interactive
Shiny document in 4 steps:

1. Add runtime: shiny to the YAML header.

2. Call Shiny input functions to embed input objects.

3. Call Shiny render functions to embed reactive
output.

4. Render with rmarkdown::run() or click Run
Document in RStudio IDE.

=— How many cars?
output: html_document
runtime: shiny 5
speed  dist
" "{r, echo = FALSE}
numericInput("n", E|[ES=Baj) 580
"How many cars?", 5) 2 4.00 10.00
renderTable({ 3 7.00 4.00
head(cars, +input$n) 4 7.00 22.00
5 8.00 16.00

Also see Shiny Prerendered for better performance.

rmarkdown.rstudio.com/
authoring_shiny_prerendered

Embed a complete app into your document with
shiny::shinyAppDir(). More at

RStudio® is a trademark of RStudio, PBC « CC BY SA RStudio « info@rstudio.com « 844-448-1212 » rstudio.com « Learn more at rmarkdown.rstudio.com » rmarkdown 2.9.4 « Updated: 2021-08

Obtén AQUI la versién en espafiol
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